GnuPG可以导致Emacs崩溃

现象描述

今天用Emacs的时候发现paradox-list-packages会导致Emacs崩溃 换成list-packages也是这样 奇怪的是 emacs -Q也会崩溃 应该不是Emacs的bug而是我自己的问题

解决方案

调试一下 错误是调用gpg.exe的时候导致的 联想到今天升级了MSYS2 马上想到是它的问题 于是用pacman -Q看了一下GnuPG包 发现它变成了未安装 应该是安装出错罢 于是pacman -S gnupg 又报错 唉 pacman -S gnupg --force 好了

总结

GnuPG可以导致Emacs崩溃 如果Emacs崩溃而又找不到问题 可以检查一下是否是它的问题 排除方法也很简单 在PATH中删除它的路径就好了